FAQ  •  Register  •  Login

Help! Can't install libraries!

Moderator: ModeratorGroup

<<

rjhuber

Posts: 2

Joined: Thu May 12, 2016 6:38 am

Post Thu Jul 06, 2017 8:31 pm

Help! Can't install libraries!

I had to do a complete re-install of Windows on my comp and as such had to re-install all programs I had installed.

Since I've re-installed Kerythea I can not install any of the libraries I've downloaded from the Kerkythea web site as I've done several times before.

I've tried using Files > Install and get a message about can not extract library type!
Library_Installation.JPG

I've tried using Settings > Materials > Open > Import and get a message about library already exists!
If it exists where is it located and why doesn't show up in Kerkythea?
Error.JPG

I've tried several library files (*.mat.zip) both ways and in every instance I get the same messages. This is directly after downloading them from the Kerkythea web site.

I also do not have any of the pre-set render settings. I've been using K for a few years now and have not had any of these issues.

Things I've tried:
- Run K as adim
- Signed in as adim and ran K
- Gave myself full rights and ownership of all folders/files in both

C:\Program Files\Kerkythea Rendering System
AND
C:\ProgramData\Kerkythea

Nothing I've tried has worked. So, any insight into this would be very much appreciated .
<<

TipsyDog

KT-Fellow

Posts: 41

Joined: Mon Nov 28, 2016 7:29 am

Location: Kiev, Ukraine

Post Fri Jul 07, 2017 6:19 am

Re: Help! Can't install libraries!

In the material name delete "(1)" after ".mat", it prevents to recognize the extension. For pre-sets: paste dir. "RenderSettings" from "C:\Program Files\Kerkythea Rendering System" to "C:\ProgramData\Kerkythea" (Or vice versa, I do not remember exactly)
<<

TipsyDog

KT-Fellow

Posts: 41

Joined: Mon Nov 28, 2016 7:29 am

Location: Kiev, Ukraine

Post Fri Jul 07, 2017 6:21 am

Re: Help! Can't install libraries!

And read the FAQ, there all your problems are described
<<

rjhuber

Posts: 2

Joined: Thu May 12, 2016 6:38 am

Post Fri Jul 07, 2017 2:38 pm

Re: Help! Can't install libraries!

Yeah, the (1) after mat doesn't matter.
Library_Installation.JPG
Library_Installation.JPG (17.83 KiB) Viewed 11828 times
<<

Fletch

KT-Team
KT-Team

Posts: 8564

Joined: Fri Oct 27, 2006 2:38 am

Location: Milwaukee, WI USA

Post Sat Jul 08, 2017 9:33 pm

Re: Help! Can't install libraries!

most likely your computer is not giving KT permissions to change the Program Files folder.
Fletch wrote:When installing a material library fails using Windows 7, or when you try to save a material library and you get an error message that the library can not be saved:

This is likely a problem with permissions - Kerkythea, when running under your user account, does not have permission to change anything in the Kerkythea program folder... such as creating a material library.

It is not too difficult to give the permissions - you don't give permission to Kerkythea, but you give permission to the User Account on the machine.

Right-click the Kerkythea Program folder (probably found here: C:\Program Files (x86)\Kerkythea Rendering System) and choose "Properties" then follow the steps listed here but you probably need to do this for your User Account, not for the Administrator account:
http://www.wikihow.com/Change-File-Perm ... -Windows-7

Use google to search for your computer system if you are using Vista or Windows 8 or 10 or other.



you can manually unzip the files into this location, and they should work fine.
C:\Program Files (x86)\Kerkythea Rendering System\MaterialEditor\Libraries
Attachments
KTlibs.png
<<

mgfranz

KT-Fellow

Posts: 29

Joined: Tue Jan 19, 2010 4:33 pm

Post Sun Aug 12, 2018 1:11 am

Re: Help! Can't install libraries!

I am having the same issue! Quite frustrating... I have uninstalled and reinstalled KT, ensured my permissions are set correctly for the User account and even tried manually creating the Materials folder and unzipping the .mat to a properly named folder, all to no avail. I cannot see any materials, I cannot install any materials. This is a brand new system, a Dell G3 running Win 10 with a Nvidia GeForce 1050 ti. Something in KT is not right! I have never ran into this problem before with my other systems.

Also, what Program Files folder is KT suppose to be installed in? I run 64 bit OS and KT wants to install in the ProgramFiles folder, not the (86) folder, will that make a difference? I did not have a MaterialEditor folder after installing KT, I had to create it as well as the Libraries folder. Creating a folder called Basic Glasses and then unzipping and inserting the files into that folder, the materials still do not show up in KT.
<<

rocso

Posts: 1

Joined: Fri Aug 17, 2018 1:42 am

Post Fri Aug 17, 2018 2:01 am

Re: Help! Can't install libraries!

A little positive feedback might ease some of the ](*,) frustation being felt hopefully.

I had the same problem as the OP and my dogs were getting worried at the :evil: noises coming from the study.

The problem was fixed eventually following the advice here:

Kerkythia version 3.0.1 (2018)
Windows Vista 32 bit (yes, it's old)

1) Install kerkythia

2) Create the folder "C:\Program Files\Kerkythea Rendering System\MaterialEditor\Libraries"

3) Set the user permissions to Full Access on the install folder C:\Program Files\Kerkythea Rendering System

4) Check that the permissions got applies recursively to the whole tree.

To confirm it worked I started Kerkythia and went to the Settings->Materials dialog, copied some materials from the left pane to the library pane and saved to a new library name. I then closed the program down and restarted it. I found the new library in the Library Selection pane of the GUI and opened it to see my materials displayed.

I was also able to install a downloaded library as per the documentation.
<<

mgfranz

KT-Fellow

Posts: 29

Joined: Tue Jan 19, 2010 4:33 pm

Post Tue Aug 28, 2018 8:14 pm

Re: Help! Can't install libraries!

rocso wrote:A little positive feedback might ease some of the ](*,) frustation being felt hopefully.

I had the same problem as the OP and my dogs were getting worried at the :evil: noises coming from the study.

The problem was fixed eventually following the advice here:

Kerkythia version 3.0.1 (2018)
Windows Vista 32 bit (yes, it's old)

1) Install kerkythia

2) Create the folder "C:\Program Files\Kerkythea Rendering System\MaterialEditor\Libraries"

3) Set the user permissions to Full Access on the install folder C:\Program Files\Kerkythea Rendering System

4) Check that the permissions got applies recursively to the whole tree.

To confirm it worked I started Kerkythia and went to the Settings->Materials dialog, copied some materials from the left pane to the library pane and saved to a new library name. I then closed the program down and restarted it. I found the new library in the Library Selection pane of the GUI and opened it to see my materials displayed.

I was also able to install a downloaded library as per the documentation.


You are using Vista 32, this problem that everyone seems to be having is directly related to 3.0 on Windows 10 64.

The only way I was able to get KT working is by using the 2008 version, yes it's old, but it still works.

Return to F.A.Q. - How do I...

Who is online

Users browsing this forum: caicai2017 and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.